Codierungen F2x

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Codierungen F2x

      Hallo liebe Gemeinde.

      Besteht hier Interesse an einem Codierthread?
      Im Nachbarforum gibt es seit wenigen Tagen ein Thread rund um dieses Thema.

      ------------Hier der Original Text vom User "Würzburger" aus dem parallelen 1er Forum------------------------

      Hilfreiche Links zum Thema Codieren gibt es viele, die meisten aber in Englisch.

      Der wichtigste Link führt euch ins Bimmerfest Forum.
      BMW Coding and Programming - Bimmerfest - BMW Forums

      Dort gibt es auf alles eine Antwort, welches Kabel, welche Software usw... Schreibt einfach shawnsheridan an, er kennt sich aus!

      Direkte Auflistungen inklusive deren Pfadangaben gibt es wenig, deb10042 hat sich aber auch die Mühe gemacht und eine solche erstellt.
      Danke dafür!
      https://docs.google.com/file/d/0B-JX...it?usp=sharing

      Meine Liste mit deutscher Erklärung findet ihr hier:
      abload.de/img/codierungenj6svs.jpg
      ssl-id.de/bullsheet.de/T/Name_p4oib1RghQMS/

      HINWEIS: Es konnten noch nicht alle aufgelisteten Codierungen getestet werden, funktionieren müssten sie aber trotzdem.

      Einige Codierungen benötigen zusätzlich angepasste Parameter, welche noch gefunden werden müssen.

      !! WICHTIG !! KEINE HAFTUNG !! WICHTIG !!

      Jeder handelt auf eigenes Risiko. Die hier angegebenen Codierungen können unter gewissen Umständen zu Schäden am Fahrzeug führen.
      Daher auch nochmals der Hinweis, dass alles auf eigene Kappe läuft und es keine Erfolgsgarantie gibt.

      Die Liste wird im Ist-Zustand zur Verfügung gestellt und kann jederzeit geändert, ergänzt oder gelöscht werden.
      Einen Changelog wird es hier nicht geben, neue Codes werden einfach unten angefügt und somit die Liste in unalphabetischer Reihenfolge fortgesetzt.

      Keine Garantie auf Richtigkeit und Aktualität!

      Bei den einzelnen Codes wurden weitestgehend die Standardwerte in [Klammern/hinzu] gefügt, falls ihr diese nicht mehr wisst und diese wiederherstellen wollt.

      ""
      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von rosswell ()

    • Ich habe jetzt mal den ersten Post überarbeitet.

      Alle Angaben ohne Gewähr und an meinem Fahrzeug (M135i, Prod.Datum: 28.06.2013) getestet.

      Was hat funktioniert:
      - SRA deaktiviert
      - Gurtwarner Fahrerseite erst ab 30km/h bzw. 500m (vorher: 10km/h oder irgendwas mit 100m)
      - Startbildschirm Navi auf die M Animation (vorher Connected Drive Animation)
      - Reserveanzeige nicht mehr bei 90 und 50km, sondern nur noch bei 20km Restreichweite
      - Momentanverbrauchsskala von 20 auf 30L
      - DVD in Motion
      - MAUT Funktion Türen (Scheiben fahren weiter hoch trotz Öffnen der Tür)
      - TFL hinten aktiv
      - TFL im iDrive komplett aktivierbar/deaktivierbar
      [- Gong beim Rückwärts fahren (Japan Gong)] -> wieder auscodiert, da nervig :D
      - Türgriff LED's an beim rückwärts fahren
      - SSA Memory
      - DVD in Motion
      - Digitale Geschwindigkeitsanzeige im Tacho
      - Uhrzeit automatisch über GPS
      - Regler für Ambientebeleuchtung im iDrive (unabhängig von Instrumentenbeleuchtung regelbar)

      Was bisher nicht funktioniert hat:
      - ASD Menü im iDrive
      - L7 Symbol im Klangmenü
      - Freischaltung des Entwicklermenüs
      - Anzeige der Drücke und Temperaturen der Reifen (wahrscheinlich keine Sensoren verbaut)

      Freue mich schon auf einen regen Austausch. :)

      Euer rosswell

      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • Wenn jemand aus der Ecke vom Bodensee kommt und ein paar Codierungen braucht, der darf sich ruhig bei mir melden.

      Ich möchte dafür auch nichts haben. Ist ja nur Hobby. ;)

      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • So, gerade eben erfolgreich das Segeln freigeschaltet... :D

      Fahrzeug: F21 M135i mit Sportautomatik
      Prod.Datum: 28.06.2013
      i-Level: F020-13-03-503 (müsste Softwarestand 2.49.1 sein)

      Folgende Einstellungen habe ich vorgenommen:

      1.) CAFD_0000023F_016_016_019.ncd --> EGS (GKEB23) --> 3000 Applikation --> "Segeln" --> "aktiv"
      2.) CAFD_0000067B_002_003_139.ncd --> ICM --> 3000 Daten --> "C_Segeln_vorhanden" --> "enable"
      3.) CAFD_000009C8_005_000_051.ncd --> KOMBI --> 3003 FZG_Ausstattung --> "SEGELN_ENABLE" --> "aktiv"
      4.) CAFD_00000DED_002_002_008.ncd --> HU_NBT --> 3000 HMI --> "EFF_DYN_SAILING" --> "aktiv"

      Nun
      noch den Haken bei "Segeln" im EcoPRO Konfigurationsmenü setzen und los gehts. Zum Testen müsst ihr im EcoPRO Modus fahren und mind. 50-60km/h auf dem Tacho haben. Dann Fuß vom Gas nehmen und die Drehzahl fällt auf ca. 600upm ab. Im Efficient Dynamics Menü unter Fahrzeuginfo seht ihr dann auch das dort "Segeln" anstatt Energierückgewinnung oder so ähnlich steht. ;)

      Achtung: KEINE HAFTUNG!! Test auf eigene Gefahr!!


      LAUNCH CONTROL
      ------------------------
      CAFD_0000023F_016_016_019.ncd --> EGS (GKEB23) --> 3000 Applikation --> "LC" --> "aktiv"

      Die Launch Control habe ich auch aktiviert. Leider habe ich noch nicht heraus bekommen wie ich die testen kann. Weiß hier jemand mehr, also welche Bedingungen müssen erfüllt sein damit die LC auch funktioniert?

      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • So, WiFi funktioniert jetzt, genauso wie das Segeln in meinem 1er mit Navi Prof aus 06/2013. :punk:

      HU_NBT > 3003 > WLAN_STATUS > aktiv
      --> Kommentar: "Switch WLAN onSwitch WLAN off"
      HU_NBT > 3003 > WLAN_MODUS > ap
      --> Kommentar: "Switch WLAN modet to Access Point (AP) / Switch WLAN mode to ClientSwitch WLAN mode to WiFi direct (simultaneous AP and Client)
      HU_NBT > 3003 > WLAN_SIGNAL_STRENGTH > "incar" for low power, "outdoor" for high power
      --> Kommentar: "Setup signal strength for in-car entertainment use cases and outdoor (Garage and Home Sync) use cases
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP_COVERART > aktiv
      --> Kommentar: "Aktiviert bzw. deaktiviert die Coverart für das UPnP/WLAN Audio."
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP_VIDEO > aktiv
      --> Kommentar: "Aktiviert bzw. deaktiviert die Coverart für das UPnP/WLAN Video."
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP > aktiv
      --> Kommentar: "Enable the DMP function to stream AV content from a connected WLAN device."

      Mein iPhone wurde mir erst nicht als Quelle angezeigt, da ich keinen DLNA/UPnP Media Server auf meinem iPhone installiert hatte. Also habe ich mir schnell mal eine kostenlose App aus dem Appstore geholt und voila, so schaut das ganze dann aus. [IMG:http://www.f10-forum.de/wcf/images/smilies/cool.png]

      Ich könnt somit jetzt jedes externe Gerät verbinden und Videos, Bilder und Musik abspielen, sofern ein DLNA/UPnP Media Server installiert ist. [IMG:http://www.1erforum.de/images/smilies/daumen.gif]

      Bilder zum WLAN und Segeln findet ihr im Anhang. :thumbup:
      Ich habe auch Videos vom Segeln und von der M Animation im Start Bildschirm gemacht. Leider weiß ich nicht wie ich die hier verlinken kann. :S

      So long.

      Euer rosswell

      Dateien
      • WLAN_1.JPG

        (229,07 kB, 17 mal heruntergeladen, zuletzt: )
      • WLAN_2.JPG

        (233,76 kB, 15 mal heruntergeladen, zuletzt: )
      • WLAN_3.JPG

        (230,79 kB, 14 mal heruntergeladen, zuletzt: )
      • WLAN_4.JPG

        (255,41 kB, 8 mal heruntergeladen, zuletzt: )
      • WLAN_5.PNG

        (77,5 kB, 10 mal heruntergeladen, zuletzt: )
      • WLAN_6.JPG

        (224,53 kB, 9 mal heruntergeladen, zuletzt: )
      • WLAN_7.JPG

        (199,67 kB, 10 mal heruntergeladen, zuletzt: )
      • Segeln_1.JPG

        (210,29 kB, 11 mal heruntergeladen, zuletzt: )
      • Segeln_2.JPG

        (207,18 kB, 10 mal heruntergeladen, zuletzt: )
      • Segeln_3.JPG

        (214,4 kB, 10 mal heruntergeladen, zuletzt: )
      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • TV Funktion im NBT Navi Prof. ab 03/13

      Danke Dir.
      Youtube hat leider nicht funktioniert. Jedes mal kommen Verarbeitungsfehler, obwohl es nur normale AVI sind. :S

      --------------------------------------------
      UPDATE
      --------------------------------------------
      Hallo zusammen,

      Nachdem ich im Bimmerfest Forum gelesen habe das das TV Modul bereits Bestandteil des NBT-Navis sein soll und die Antennen auch verbaut sein sollten sofern man DAB bestellt hat, dachte ich mir, dass ich das doch mal ausprobieren könnte. :rolleyes:

      Ob es letztendlich wirklich funktioniert kann ich noch nicht sagen, da ich hier auf dem Land generell keinen DVB-T Empfang habe. Ich werde es jedoch testen, sobald ich wieder in einer Stadt bin. ;)

      Falls das mal jemand von Euch testen mag, dann hier die Einträge dazu:

      HU_NBT / 3000 HMI
      TVM_VARIANTEN --> "tvm_verbaut"
      CDMM_TV_EPG_AUTOSTORE --> "aktiv"
      CDMM_TV_BML --> "aktiv"
      CDMM_TV_TELETEXT --> "aktiv"
      CDMM_TV_SUBTITLES --> "aktiv"
      CDMM_TV_PAY_BROWSER_LIST --> "aktiv"
      CDMM_TV_FOLLOWING --> "aktiv"
      CDMM_TV_PRESETLIST --> "aktiv"
      CDMM_TV_AUDIOTRACK --> "aktiv"
      CDMM_TV_EPG --> "aktiv"

      So long.

      Euer rosswell

      Dateien
      • TV.JPG

        (330,61 kB, 17 mal heruntergeladen, zuletzt: )
      • TV_2.JPG

        (266,63 kB, 13 mal heruntergeladen, zuletzt: )
      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • Wenn du wüsstest. Es gibt hunderte von Parametern die man verändern kann. :D

      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • Bezüglich der Launch Control habe ich bei meinem M135i mit Prod.datum 28.06.2013 jetzt folg. versucht:

      1.) Softwarestand von 2.49.8 auf 2.50.4 bei BMW aktualisieren lassen
      2.) Zeitkriterium von 0313 auf 0713 im Fahrzeugauftrag abgeändert
      3.) alle Steuergeräte neu codiert

      Fazit: Geht immer noch nicht, da der Punkt im DSC weiterhin fehlt. Ich denke da wird es ein Hardwareupdate gegeben haben, anders kann ich mir das nicht erklären. :wink:

      Vorteile von der oberen Vorgehensweise:
      - Segeln sofort aktiviert
      - neue Grafik in den erweiterten Inst. Display bei EcoPRO Modus
      - M135i unterm Drehzahlmesser aktiviert
      - Zeiteinstellung im iDrive auf automatisch
      - Lautstärkeeinstellung als Popup
      - ...

      Nachteile:
      - bisher keine entdeckt... :mrgreen:

      ACHTUNG:
      Das Zeitkriterium nach codieren der Steuergeräte wieder zurückändern falls das Fahrzeug mal wieder zu BMW muss. Denn das fällt dann auf. :mrgreen:

      EDIT: LC hin oder her, der Wagen hat trotzdem Schlupf ohne Ende. Sprich so wirklich bringen tut das nichts. ;)

      Offizieller Ansprechpartner Forumshändler BMW Matthes
      BMW Matthes Preislisten --> *klick mich*
      Codierer für F-Modelle im süddeutschen Raum. ;)
      Bei Interesse an Nachrüstungen (z.B. Tempomat) einfach melden.
    • rosswell schrieb:

      So, WiFi funktioniert jetzt, genauso wie das Segeln in meinem 1er mit Navi Prof aus 06/2013. :punk:

      HU_NBT > 3003 > WLAN_STATUS > aktiv
      --> Kommentar: "Switch WLAN onSwitch WLAN off"
      HU_NBT > 3003 > WLAN_MODUS > ap
      --> Kommentar: "Switch WLAN modet to Access Point (AP) / Switch WLAN mode to ClientSwitch WLAN mode to WiFi direct (simultaneous AP and Client)
      HU_NBT > 3003 > WLAN_SIGNAL_STRENGTH > "incar" for low power, "outdoor" for high power
      --> Kommentar: "Setup signal strength for in-car entertainment use cases and outdoor (Garage and Home Sync) use cases
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP_COVERART > aktiv
      --> Kommentar: "Aktiviert bzw. deaktiviert die Coverart für das UPnP/WLAN Audio."
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP_VIDEO > aktiv
      --> Kommentar: "Aktiviert bzw. deaktiviert die Coverart für das UPnP/WLAN Video."
      HU_NBT > 3000 > ENT_MC_WLAN_STREAM_DMP > aktiv
      --> Kommentar: "Enable the DMP function to stream AV content from a connected WLAN device."

      Mein iPhone wurde mir erst nicht als Quelle angezeigt, da ich keinen DLNA/UPnP Media Server auf meinem iPhone installiert hatte. Also habe ich mir schnell mal eine kostenlose App aus dem Appstore geholt und voila, so schaut das ganze dann aus. [IMG:http://www.f10-forum.de/wcf/images/smilies/cool.png]

      Ich könnt somit jetzt jedes externe Gerät verbinden und Videos, Bilder und Musik abspielen, sofern ein DLNA/UPnP Media Server installiert ist. [IMG:http://www.1erforum.de/images/smilies/daumen.gif]

      Bilder zum WLAN und Segeln findet ihr im Anhang. :thumbup:
      Ich habe auch Videos vom Segeln und von der M Animation im Start Bildschirm gemacht. Leider weiß ich nicht wie ich die hier verlinken kann. :S

      So long.

      Euer rosswell
      Hi Grüß dich Matthes ich hab bei mir auch die ganzen erforderlichen schritte durchgeführt jedoch kriegeich den haken bei WLAN nicht aktiviert bzw. es tut sich halt nichts :( ich hab ich da was falsch gemacht ?

      lg
      kar1zma